Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: VTM questions

  1. #11
    Join Date
    Jul 2004
    N29° 22.725' X W95° 6.452'
    My fault, I am actually using MySQL v4.0.17, since you are using 4.1 read this:

    MySQL 4.1 and up uses an authentication protocol based on a password hashing algorithm that is incompatible with that used by older clients. If you upgrade the server to 4.1, attempts to connect to it with an older client may fail with the following message:

    shell> mysql
    Client does not support authentication protocol requested
    by server; consider upgrading MySQL client

    To solve this problem, you should use one of the following approaches:

    Upgrade all client programs to use a 4.1.1 or newer client library.

    When connecting to the server with a pre-4.1 client program, use an account that still has a pre-4.1-style password.

    Reset the password to pre-4.1 style for each user that needs to use a pre-4.1 client program.

    This can be done using the SET PASSWORD statement and the OLD_PASSWORD() function:
    -> 'some_user'@'some_host' = OLD_PASSWORD('newpwd');

    Alternatively, use UPDATE and FLUSH PRIVILEGES:
    mysql> UPDATE mysql.user SET Password = OLD_PASSWORD('newpwd')
    -> WHERE Host = 'some_host' AND User = 'some_user';

    Substitute the password you want to use for ``newpwd'' in the preceding examples. MySQL cannot tell you what the original password was, so you'll need to pick a new one.

    Tell the server to use the older password hashing algorithm:

    Start mysqld with the --old-passwords option.

    Assign an old-format password to each account that has had its password updated to the longer 4.1 format. You can identify these accounts with the following query:
    mysql> SELECT Host, User, Password FROM mysql.user
    -> WHERE LENGTH(Password) > 16;

    For each account record displayed by the query, use the Host and User values and assign a password using the OLD_PASSWORD() function and either SET PASSWORD or UPDATE, as described earlier.

  2. #12
    Join Date
    Jul 2003
    Originally posted by shub

    I made the change and get the same error.
    Sorry. that was for checking path error. not sure what I was thinking.

    like mcarman said, just change the password of your "php" user account in mysql using OLD_PASSWORD("f00").

    - go into mysql
    - use mysql
    - view "user, password" field in the user table
    - UPDATE user SET Password=OLD_PASSWORD("f00") WHERE user="php";
    - view user table again and you should see that your password has a lot less digits

  3. #13
    Join Date
    Nov 2004
    After reading through everything, I chose to try:

    mysql> UPDATE mysql.user SET Password = OLD_PASSWORD('newpwd')
    -> WHERE Host = 'some_host' AND User = 'some_user';

    everything is working properly now. It seems that it is just a matter of the hashing used in the password for mySQL.

    Thanks for all of the help!!!

  4. #14
    Join Date
    Jan 2003
    This one sound familiar for me, because i also got this error once.
    If you are running one partition on your HDD, it will be a little bit problems to make this running, so i recommend you to make a new partition on your HDD and use D:\ as a Web-server.

    I always got conflicts when i used one partition, but the problems was gone after i splitted my HDD.

    PS! You must not use more than one webserver on one single computer (EX: Apache and IIS together ... it's not good)

  5. #15
    Join Date
    Nov 2004
    I had exactly this error when I was setting AMP (Apache, PHP, MySQL) up on a server. Turns out that there is a .dll file called libmysql.dll in the PHP dir that I had to copy to C:\Windows\system32\. After I copied the file over it ran perfectly, both on a development server @ work and another Development Server @ home. I'm running Apache 2.0.52, MySQL 4.3 Gamma and PHP 5.02 BTW

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts