Results 1 to 10 of 96

Threaded View

  1. #11
    Join Date
    Sep 2006
    Location
    Atlanta GA
    Posts
    51

    Security Camera Multiplayer fix

    If you watch Buzz's VTM for the security camera he says towards the begining of the video that the security camera only works in a single player game, or in an offline game.

    Angel Mapper has a fix for this on her site.

    I'll just post the most important part.

    IT"S A GOOD IDEA TO DO THIS FIRST, THEN FOLLOW BUZZ's tutorial.


    Maabus from the Atari forums has also come up with a solution to getting the cameras to work online..


    FIX:
    In the Actor browser, right click on the CameraTextureClient and hit New. Give it a name, and set the Package to mylevel. Hit OK and a new window will pop up. Hit the Compile Changed Scripts button (three sheets of paper), then once it's done, close out that window. In the Command line at the bottom of UEd, type editdefault class=mycameratextureclient, or whatever name you gave it. This will pop up the default property window for it. Under None, look for RemoteRole, and change it to ROLE_SimulatedProxy. Close it out, then use this class instead of the normal CameraTextureClient and it will work online. You may have to uncheck Placeable Classes Only in the Actor browser to get it to show up.


    *I had no problems on the "placeable" part.
    Last edited by ShredPrince3; 10-17-2006 at 11:27 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •