Results 1 to 9 of 9
  1. #1
    Join Date
    Jul 2010
    Posts
    472

    See-Through Third-Person Character

    Hey all,

    I was wondering if there was something I was just doing that was 'weird' or if I was somehow importing something wrong, or if Unity's just changed how they do things dramatically... or if the original model has always had this problem.

    The character provided in the Third-Person camera set of videos is see-through, or ... clips itself, or something of that nature. After a little research, a lot of people suggest it might be the model's normals, but I'm wondering if this is an issue I'm the only one having, or if it's an actual issue that either I can fix (With only the FBX), or if someone else has already fixed?

    Granted, I'm just using the character as a placeholder, so it won't be there any longer than I need it to be, but it'd be nice to have something presentable while I'm working on my own model, just to show the world off a little bit. Give a taste of the future, and all that.

    Thanks!
    "It's most impressive when it's least expected."

  2. #2
    Join Date
    Aug 2010
    Posts
    160
    Are you saying that on zooming the character model can collide with the camera frustum's near clipping plane and you can see through the model? If so that is the correct behavior the inside of a model should not be rendered as it would be a waste of rendering cycles to do so.

  3. #3
    Join Date
    Jul 2010
    Posts
    472
    Nope, I expect that behavior. What I mean is that rotating around the character, the character's head and back actually are see-through to a degree, even if I'm sufficient distance to avoid camera collision.

    It's almost like if you're looking at the legs, the opposite-side's leg might be overlapping the closest leg.
    "It's most impressive when it's least expected."

  4. #4
    Join Date
    Jul 2010
    Posts
    472
    For a visual representation...
    Click image for larger version. 

Name:	Screen Shot 2016-11-22 at 8.39.19 PM.png 
Views:	105 
Size:	1.58 MB 
ID:	74665

    I have five other images from different angles pointing out different things, but this one probably gives sufficient information about what I mean. This is in Game mode and as I use the right mouse to rotate around the camera... clearly plenty far away, the character's capable of being seen through to the point it looks like everything about her is transparent.

    This happens every time I import the FBX, regardless of settings, regardless of how much I change the import settings. This happened a long time ago when I went through this course, too, but I never brought it up, figuring maybe I was doing something wrong (Since I imported it mostly on my own).

    This time, I followed every detail of importing in the videos. So, since the issue still exists......... curious if I'm the only one with this problem, and/or how I might go about fixing it.
    "It's most impressive when it's least expected."

  5. #5
    Join Date
    Aug 2010
    Posts
    160
    That model is jacked up. I have never seen that. even though i did that course, i used a model i already had. Have you tried importing it into another model viewer / 3d modeling program to see if it still repros the same issue?

  6. #6
    Join Date
    Jul 2010
    Posts
    472
    I pushed it into Maya without textures and it looked completely solid. I didn't apply the materials. For some reason the materials don't like to come along on their own, so you have to coax them. In Unity, I have to change the setting under 'Material Naming' from 'By Base Texture Name' to 'From Model's Material'. Not sure why Maya doesn't automatically pull the textures in.

    Mind, literally everything else works, including animation. It's just see-through. But it just seems puzzling because I didn't see it in the videos. In the videos it's a normal, solid character from any angle. Which is why I was wondering if it was just me a while back ago.
    "It's most impressive when it's least expected."

  7. #7
    Join Date
    Dec 2009
    Location
    Atlantis
    Posts
    167
    looks like your using the wrong shader, if thats the model from 3DBuzz its pretty old. Unitys shaders have changed a lot since then, try one of the other unity shaders on it.
    Last edited by GreyWalker; 11-24-2016 at 03:42 PM.

  8. #8
    Join Date
    Jul 2010
    Posts
    472
    Thanks for the suggestion. I considered that, because I remembered seeing a shader option somewhere, but I can't remember where I saw it... guess I'll jump through the videos again and see if I can find the right one to change the shader.
    "It's most impressive when it's least expected."

  9. #9
    Join Date
    Jul 2010
    Posts
    472
    Was able to find the place to change the shader, and sure 'nough, changing it to a legacy shader made it work. She isn't see-through anymore.
    "It's most impressive when it's least expected."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •