Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11
    Join Date
    Feb 2009
    I think had the same error when I went through it or at least similar, if I remember correctly.. the error names seem to run together after a while, they're so similar.

    I'm sure you've done this all, but how about...

    Have you tried changing the File="" line to do a static location on your HDD, rather than a dynamic? throw into c:\temp and try to run the build command there.

    My references to System.Net.Http are in the Web, Launcher, and Build.Tasks, project references. I'm using v4.0.30319. Its located at: C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\.NETFramework\v4.5. 1\System.Net.Http.dll

    If you still get the error, you could watch the system events on your remote server. It should be logging everything that comes that way, so you'll know if it just got refused, or if there was no connection.

    Hope any of that helped! At least you can maybe cross some things off your list of what's NOT wrong..

    And ya, I know there's more people.. That Unity 5 with MMO thread has over 2 thousand views. lol, it can't just be the 4 of us! ;-D
    Last edited by imlladris; 06-12-2015 at 10:51 AM.

  2. #12
    Join Date
    Feb 2014
    Fixed at last.
    I fortunately still had the old VM when I did the videos last time around, and that still worked which seemed to make it a configuration error.

    So I decided I wanted 3 real environments - the real servers would now be the prod environment and I would keep the VM as sta... why not? I should have done that in the first place.

    It turned out that my problem was in the BuzzMMOBuild.proj file where the environment was defined.

    Here is my sta environment that goes to my VM:
    <PropertyGroup Condition="'$(Env)' == 'sta'">
    Here is the new working prod bit that hits the external servers (note the domain is just the server name in this instance cos their real domain would entail the request going out via the internet rather than just the LAN:
    <PropertyGroup Condition="'$(Env)' == 'prod'">
    I made the Parameters.Production.config and Paramaters.Staging.config match the names of the IIS website name and where the mysql database was and presto. I won't quote them here because they have passwords and stuff in them.

    I have to say however, that MSBUILD is really taking a hit as my top 10 favourite software.

    Sorry to hijack the thread. A bit hard to get back to topic now.
    Where in this error "Error uploading file: NotFound, System.Net.Http.StreamContent" could I suspect it was in the config.....
    Last edited by oldngrey; 06-14-2015 at 03:49 AM.

  3. #13
    Join Date
    Feb 2014
    Ha.... Nelson had this exact same error in the video Teamcity ASP NET. The 'domain' parameter even caught him out!

  4. #14
    Join Date
    Jan 2007
    I had to restart the MMO videos form Chapter 10 due to various reasons and them my main development system died (required at least one RMA).

    MSDeploy worked for me, once I figured out how to deploy form a 64-bit system to a 32-bit system . This time I don't have to worry about the bitness issue.. I just need my workstation back!

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts