Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    Join Date
    Dec 2009
    Location
    Atlantis
    Posts
    167

    End of chapter 11

    I finally got to the end of chapter 11 and looking forward for the next chapter to begin, I noticed a couple of differences between my project and MMO class tho, if anyone has any problems going through the chapter then I've probably encountered it lol.

    Inside of unity there are some buttons added to the Unity project for debugging.

    Click image for larger version. 

Name:	Unity.png 
Views:	164 
Size:	219.1 KB 
ID:	74481

    and also there is a CharacterSelectSystem.cs in the BuzzMmo.Base project as well as master server and region server logs.

    Have I missed these parts while going through the videos or have these been added during Nelsons own development in the background?
    Last edited by GreyWalker; 06-09-2015 at 06:11 PM.

  2. #2
    Join Date
    Feb 2009
    Posts
    69
    If I remember correctly, the CharacterSelectSystem was added just as a quick test of the Assembly scanner. He dropped it in in about 10 seconds on one of the videos durring the RPC work. I don't believe it actually did anything, and he quickly moved on to creating the ping pong tests that we actually have. The server logs he started working on, then realized that he hadn't hooked up logs for the servers yet, and instead looked into the Photon logs to check on a debug, so you haven't missed that either. I'd say you're right where he left off!

    I'd say you're sitting pretty at this point. Unless I've missed the same things you have! ;-)

  3. #3
    Join Date
    Aug 2010
    Posts
    160
    I would agree. That is the same as me.

  4. #4
    Join Date
    Dec 2009
    Location
    Atlantis
    Posts
    167
    Happy days! cant wait for the next part to start, in the mean time I think I'll work on creating some terrains.

  5. #5
    Join Date
    Feb 2009
    Posts
    69
    All we need is oldngrey to pipe in, and we'll have the louder portion of the MMO coders eagerly awaiting nelson's highly anticipated return to the MMO!

    I did the Blender Course SJC has been putting together whilst waiting... I mean, your gonna need assets right? ;-)

  6. #6
    Join Date
    Feb 2014
    Posts
    277
    pfft.... I do hope that more than just us few are following along with this series. I'd hate to think it ever dies out due to lack of interest. I haven't found a lot of stuff out there that is doing a serious mmo - and I don't mean multi-player.

    I hope Nelson goes back and completes a few missing features though - the https stuff for a start that was removed in the deploy remotely video. I chose Unity3d and the asset store so I didn't have to know about art..... (I also subscribe to Arteria3d for this artwork. Nice)

    I've been doing the asp mvc course to fill in the days and also redoing chapter 10, this time on real server2012 servers - 3 in fact. Guess what, my errors are all different this time around. I am not becoming too fond of MSDEPLOY and the many many ways it can fail.
    Last edited by oldngrey; 06-12-2015 at 01:58 AM.

  7. #7
    Join Date
    Feb 2009
    Posts
    69
    I didn't mean to imply that there were only a few of us following, just that we were the more vocal of them. ;-)
    And yea, the https portion of the remote deploy is a pretty big point to skip over. I've tried a few times to rectify that, but i keep getting strange, un-googleable errors, that have less description than i'd like. Its almost like whoever designed that decided documentation wasn't in his job description.

    Are you at least getting the same error on all 3 servers? Or is it a different error per server?

    I ended up going with a 2008 R2 server, that i found online for 7$ a month. The only ones I could find with 2012 were 30-50 range.

  8. #8
    Join Date
    Feb 2014
    Posts
    277
    My 3 servers all do a different function. They are in my study on a different ISP than my workstation.
    One is a domain controller and the mysql server.
    The second one is the buzzmmo web server and team city.
    The third server is dedicated to Photon.
    That's my test environment and should handle all my development and even final testing.

    The current error is just the one error where I run the msbuild command to send up the launcher.zip.
    Remember typing this in??:
    D:\C#\BuzzMMO\src>msbuild BuzzMMOBuild.proj /t:
    DeployLauncher /p: Env=sta /p: DeployToken=A+bQ2qwrr+xKePN/PGEXMqOFfhxttOFmyf/vISkYIgjMDaqFCEJmO81obvHA6I+txWoP7ITEEs4OKCJLDUjee g==
    It looks like it hasn't even left my workstation.
    Launcher.zip is made and then it then throws an error as soon as it goes to the upload bit:

    Build FAILED.

    "D:\C#\BuzzMMO\src\BuzzMMOBuild.proj" (DeployLauncher target) (1) ->
    (DeployLauncher target) ->
    D:\C#\BuzzMMO\src\BuzzMMOBuild.proj(65,2): error : Error uploading file: NotFound, System.Net.Http.StreamContent

    0 Warning(s)
    1 Error(s)
    The 65,2 bit refers to the line in BuzzMMOBuild.proj line 65 where it defines the upload parameters:
    <UploadFile
    Type="Launcher"
    Env="$(Env)"
    Domain="$(Domain)"
    DeployToken="$(DeployToken)"
    File="../Build/Launcher/Launcher.zip"
    Timestamp="$(Timestamp)"
    VersionNumber="$(VersionNumber)" />
    The really odd thing about this is that the Launcher.zip and System.Net.Http.dll certainly does exist in many places and that I did this video successfully a few months ago. So far it's stumped me.... but then again, it's not the fist time msbuild has been nasty to me!
    Last edited by oldngrey; 06-12-2015 at 09:32 AM.

  9. #9
    Join Date
    Aug 2010
    Posts
    160
    I didn't do the MS deploy videos as I am hosting my site on Azure and using Visual Studio Online instead of BitBucket. You can set up publishing site through repository and all of my web traffic is over https. Considering you can have 10 free websites on Azure right now and they all come with basic https if you don't use a different domain it was an easy choice

  10. #10
    Join Date
    Dec 2009
    Location
    Atlantis
    Posts
    167
    There has got to be more than a few lurkers in the background, most of my posts are about problems I had with MSDeploy, and those posts have view counts 500+, I've had a quite a few dramas with MSDeploy the the error messages are so ambiguous, at one point I reached out to Microsoft through my BizSpark account to get help and it was malware on my PC stopping MSDeploy interacting with my VM, also I had BitDefender installed on my machine and this also stopped ANY interaction between MSDeploy and my VM, add exceptions to the firewalls, IP's Bit Defender just blocked everything. Only way to get it to work in the end was to remove BitDefender from my system.

    I also got an "error : Error uploading file: NotFound, System.Net.Http.StreamContent" this was after installing a new hard drive on my machine. where previously the code all worked fine, the solution was that on my old hard drive my folder structure was
    Code:
    "C:\Users\GreyWalker\Documents\Visual Studio 2013\Projects\DystopiaOnline"
    but when I moved to my new hard drive I had set up the user as Grey Walker with a space in the folder file name

    Code:
    C:\Users\Grey Walker\Documents\Visual Studio 2013\Projects\DystopiaOnline
    after digging around on the net I found out that if you have any spaces in the filepath then you need to wrap the filepath in double quotes. I'll go through my code later tonight and post a code snippet of an example of where if had to use double quotes in some cases where Nelson has used single quotes.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •