Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15
  1. #11
    Join Date
    Nov 2006
    Location
    Vancouver, WA
    Posts
    236
    More info


    Error line from commandprompt
    C:\Users\Documents\MMO_Codebase\src\MMOBuild.proj( 69,5):error MSB4018: at MMO.Build.Tasks.UploadFile.Execute() in
    c:\Users\Documents\MMO_Codebase\src\MMO.Build.Task s\UploadFile.cs:line 51\r

    UploadFile.cs

    Code:
    49            var client = new HttpClient();
    50            //Https and Http
    51            var response = client.PostAsync(string.Format("https://{0}/api/v1/{1}/upload", Domain, apiEndpoint), multipartData).Result;
    52            //var response = client.PostAsync(string.Format("http://{0}/api/v1/{1}/upload", Domain, apiEndpoint), multipartData).Result;
    53
    54            if (!response.IsSuccessStatusCode)
    55                Log.LogError("Error uploading file: {0}, {1}", response.StatusCode, response.Content.ToString());
    56
    57            return response.IsSuccessStatusCode;

  2. #12
    Join Date
    Mar 2004
    Location
    Anacortes, WA
    Posts
    4,168
    Quote Originally Posted by Matroblend View Post
    More info


    Error line from commandprompt
    C:\Users\Documents\MMO_Codebase\src\MMOBuild.proj( 69,5):error MSB4018: at MMO.Build.Tasks.UploadFile.Execute() in
    c:\Users\Documents\MMO_Codebase\src\MMO.Build.Task s\UploadFile.cs:line 51\r

    UploadFile.cs

    Code:
    49            var client = new HttpClient();
    50            //Https and Http
    51            var response = client.PostAsync(string.Format("https://{0}/api/v1/{1}/upload", Domain, apiEndpoint), multipartData).Result;
    52            //var response = client.PostAsync(string.Format("http://{0}/api/v1/{1}/upload", Domain, apiEndpoint), multipartData).Result;
    53
    54            if (!response.IsSuccessStatusCode)
    55                Log.LogError("Error uploading file: {0}, {1}", response.StatusCode, response.Content.ToString());
    56
    57            return response.IsSuccessStatusCode;
    Yeah, the error on the build script is just saying that there was an error on the server.

    Is that all of the information you get when you see the exception on the server? You don't see any sort of exception details?
    Need any help? Feel free to PM me - or send an email directly to nelson@3dbuzz.com!

  3. #13
    Join Date
    Nov 2006
    Location
    Vancouver, WA
    Posts
    236
    Does this mean anything?

    Step into: Stepping over non-user code 'MMO.Web.Infrastructure.UploadService.<>c__Display Class1..ctor'
    A first chance exception of type 'System.AccessViolationException' occurred in System.Net.Http.Formatting.dll

  4. #14
    Join Date
    Feb 2015
    Location
    Turkiye
    Posts
    18
    It's been a long time but maybe someone comes here, the problem is most likely related not to have this adjustment:
    http://s33.postimg.org/z6q7tj48v/app..._anonymous.png

    Edit: Without changing anonymous user identity, if you open the folder "c:\windows\system32\inetsrv\config" once and then run again the deploy launcher build configuration in teamcity, you'll get a success. But in this case, reopening the virtual machine will make the security settings of the config folder just like before the success. It's weird. I made hundreds of test builds, (lucky to have restore functionality in virtual box) but i couldn't find a decent explanation.
    Last edited by byagcioglu; 06-16-2016 at 12:30 PM. Reason: extra information (second thoughts)

  5. #15
    Join Date
    Feb 2014
    Posts
    277
    I have
    Anonymous Authentication enabled
    Anonymous user identity is "Specific User" set to IUSR

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •