Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2014
    Posts
    1

    Tiling / Snapping Issue

    Hi gents,

    Working through your 2D tutorial, but having an issue getting my sprites to snap properly. I followed the tutortial, and checked all of the numbers I could see, but my textures aren't filling the full size. (image for reference: http://imgur.com/8vy783u )

    Would really appreciate any assistance with where I'm going wrong!

    Many thanks, and really enjoying the series thus far.
    Purpose

  2. #2
    Join Date
    Aug 2014
    Posts
    7
    I had to futz with the numbers they gave as well a little to get them really on close.

  3. #3
    Join Date
    Aug 2011
    Location
    Kansas
    Posts
    181
    I had a similar problem, but only with certain sprites. I wonder if doing the automatic sprite slicing results in slightly different results for everyone... maybe depending on what version of Unity? 4.52, 4.53, etc?

    I played around with them enough that I got it looking good, so I didn't worry about it.

  4. #4
    Join Date
    Aug 2011
    Location
    Kansas
    Posts
    181
    I played around with it some more and found my problem. In the sprite editor, the box for slicing the sprite was off by 1 pixel in my case. I adjusted that (For DirtFull, I used X: 640, Y: 0, W: 384, H: 384) and the problem went away.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •