Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2002
    Location
    Canada
    Posts
    172

    Question 2 UV Mesh in unity is only displaying the first UV set

    Hello everyone,
    I am trying to learn Unity, and I am working on importing a mesh of a dart I modeled in Lightwave.

    The mesh contains two UV sets. The first set is for the dart's metal, which will be the same for all darts. The second UV set is for the feathers and two rings that are around the dart's weight. This will be different depending on the dart, either red, blue or green, and will use the appropriate texture for it.

    The first UV set works fine, but the problem is when I try to apply the colour texture I created to the second UV set, nothing appears at all, it is as if the texture is 100% transparent.

    Am I missing some setting to show the 2nd UV set? I have been searching for this answer for hours and have not come up with any solution to my problem.

    I have created an image to show what it looks like in Lightwave and Unity, so as to better explain what I mean.
    Click image for larger version. 

Name:	dart.jpg 
Views:	442 
Size:	209.1 KB 
ID:	74159

  2. #2
    Join Date
    Sep 2002
    Location
    Canada
    Posts
    172
    well I after 2 days of searching I finally found the answer to my problem, so I will post the answer in case any one searching for the answers to the same problem come upon this thread.

    It turns out that Unity only uses the 2nd UV set on a mesh for light mapping. It can be used for texturing, but would require writing custom shaders. This is true for at least up to version 4, perhaps 5, but like anything this may change in the future.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •