Results 1 to 4 of 4
  1. #1
    Join Date
    Dec 2011

    Detail meshes not painting, and rocks moving

    I am having several ongoing problems with painting detail meshes in unity. I am running version 4.1.2, and I am weary of updating, so unless you know that fixes the issues I'm about to list, please don't suggest it.

    Problem 1: Some detail meshes wont paint. These are detail meshes I bought in the unity store- so by all means they should work.

    When I... Edit Details> Add Detail Mesh> select my mesh> color's desaturated greys, render mode vertexlit> add
    it shows up in the box the way it should. I can select that mesh, and I have my paintbrush size and density set the way they should be (I have even experimented with different size and density combinations just to be sure). When I go to paint it.. there is nothing.
    I have tried on different slopes. I have tried zooming way in to see if the are just not rendering from a distance. I have gone into play mode and run right over to where it should be, and there is nothing.
    Certain detail meshes DO paint for me. I can paint the grass clumps, ferns, and things like that from this pack... but the rocks, stumps, logs, mushrooms, etc do not paint. I am also able to paint on the rocks from the standard asset pack, so if anyone has any ideas why this isn't working, please let me know.

    Problem 2: The rocks that I can paint from the standard asset pack move in the wind like plants.

    Seriously, they look like someone made a flag with a picture of a rock on it, stuck it in the ground, and its gently billowing in the breeze.
    I have double checked that I have the render mode on vertexlit, I have removed any rigging and animation from the rock mesh... and still they do this.

    I have a feeling that these two issues might be related, since the only detail meshes I can get unity to place are plants that move, and rocks..that move....

    No clue what went wrong or how to fix this, and there is a sad lack of answers to this problem on the internet.
    Thanks for taking the time to read this, and all help is appreciated!


  2. #2
    Join Date
    Dec 2011
    168 views and still no answers? Bumping this because it's still a huge problem and no one has given any answers yet. Any idea who I might contact to figure this out?

  3. #3
    Join Date
    Oct 2011
    I overlooked this post. Also, I think I have answered this topic already, on this forum.

    However I will also take a look to check the issue and to verify my answers for this.

    Atm at a phone. Will look into it. Placed this mostly as a reminder.

    PS: Next time make the bump after a week or so . Also people that view might not know the answer or are currently unable to answer so they place it in for later bin, so don't be discouraged.

  4. #4
    Join Date
    Dec 2011
    So I have solved this issue finally. It turns out that in a pack of objects I got for my project, they came with a custom shader. I never actually did anything with this shader, it was just sitting in the asset pack it came from, but somehow it still affected anything with a certain type of texture. This is what was causing all my objects to react this way. After having removed the shader, everything now paints as it should, and all meshes behave properly.
    To double check, I imported the shader again and bam, things went weird again. Removed the shader again, stuff back to normal. So there you have it, you dont even have to use them apparently for them to have an effect. How strange.

    For anyone who ever runs across these problems, check for shaders that sneak in when you import packages first!
    Last edited by Cherrytree1118; 06-06-2014 at 07:51 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts