Results 1 to 4 of 4
  1. #1
    Join Date
    May 2009
    Posts
    199

    Error adding schema privileges to new DB user

    Hi,

    I'm using the latest version of MySQL for the MMO class.
    I downloaded and installed it today without a hitch but following along with Nelson's class from last week I get an error...



    In MySQL Workbench I create a new user, dev_runeslinger, and add a new entry in the schema privileges tab.
    After selecting the rights and hitting save the above error appears.
    A quick Google brought up tons of results relating to this error code but I've not found any for this specific situation.

    P.S. The default Engine which I chose for the users table is InnoDB in case it makes any difference.

    Any ideas anyone?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DBError.PNG 
Views:	597 
Size:	15.5 KB 
ID:	73464  

  2. #2
    Join Date
    May 2009
    Posts
    199
    I posted this same question on StackOverflow and was informed that this is a known bug in the latest versions of MySQL Workbench.
    The bug report can be found here.

    Recent versions of Workbench, when dealing with database names containing underscores(_), incorrectly escape the underscore characters with a backslash so the result in my case was dev\_runeslinger being inserted into the generated SQL statement which is an error in syntax.

    I worked around the bug by recreating my database with the name runeslingerdb.

  3. #3
    Join Date
    Aug 2011
    Location
    WA State
    Posts
    40
    I was getting the same error but punted past it using global permissions for the sake of the class.
    I'll go back in this week and re-work the db name.
    Thanks for posting that, Dack.

    -Seth

  4. #4
    Join Date
    May 2009
    Posts
    199
    You're welcome mate, glad someone found it useful

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •