Hi guys, I have been trying to figure out an unrealscript error lately.

Everytime I want to spawn an actor with the following default properties:

Code:
defaultproperties
{    
    bCollideActors=false
    bCollideWhenPlacing=false
    bCollideWorld=false

    Components.Add(MyLightEnvironment) // if this is missing the camera mesh will be all black

    
    Begin Object Class=StaticMeshComponent Name=AutomaticMeshComponent0
        StaticMesh=StaticMesh'EngineMeshes.Cube'
        bCastDynamicShadow=FALSE
        BlockRigidBody=FALSE
        bForceDirectLightMap=FALSE
        bAcceptsDynamicLights=FALSE
        bAcceptsLights=FALSE
        CastShadow=FALSE
        bUsePrecomputedShadows=FALSE
        bAcceptsStaticDecals=FALSE
        bAcceptsDynamicDecals=FALSE
        bUseAsOccluder=FALSE
        bSelectable=FALSE
        bIgnoreOwnerHidden=TRUE
        WireframeColor=(R=100,G=100,B=200,A=255)
    End Object
    AutomaticMeshComponent=AutomaticMeshComponent0
    Components.Add(AutomaticMeshComponent0)

    // Might be the cause of error
    Begin Object Class=FogVolumeConstantDensityComponent Name=FogVolumeComponent0
                Density=0.0005
                FogMaterial=Material'EngineVolumetrics.FogEnvironment.Materials.M_EV_FogEnvironment_Master_01'
    End Object
    DensityComponent=FogVolumeComponent0
    Components.Add(FogVolumeComponent0)


}
I always get the error:
error: appError called: Cast of DepthCamera ImprovedTestRoom.TheWorld:PersistentLevel.DepthCam era_0 to FogVolumedensityInfo failed
So, can anyone of you guys help me.
Thanks, looking forward for your answers!