Results 1 to 3 of 3

Thread: RavenDB Help

  1. #1
    Join Date
    Jan 2011
    Posts
    102

    RavenDB Help

    SOLVED (FIX) I'm using Visual Studios 2008, and need to use the dll's in 'Client3.5' folder. Just in case anyone gets the same issue. Can't access AsyncCtpLibrary.dll and still get problems with Newtonsoft.Ison.dll, but I'm not exactly sure what that's used for yet.


    Just started going through the videos. I added the References to the Client. However when I add them they show a Warning sign on top of them /!\. I figured I would ignore it temporarily, and continue on. However when I try to add in
    'using Raven.Client.Document', it won't detect it. Any help would be greatly appreciated.


    Edit 1 - My project folder is on the desktop, so I thought if I put the Raven-DB folder on the desktop that may solve the issue, unfortunately not. Maybe I've missed a simple step I'll go back through the videos again.

    Edit 2 - It works if I use references to Client3.5, so I assume something is broken within the Client folder? I tried removing the folder and re-downloading, that didn't fix the problem.

    Edit 3 - I tried adding reference path directly, I'm running out of ideas :/
    Last edited by jimmiduff21; 02-17-2011 at 05:51 PM.

  2. #2
    Join Date
    Mar 2004
    Location
    Anacortes, WA
    Posts
    4,168
    Quote Originally Posted by jimmiduff21 View Post
    SOLVED (FIX) I'm using Visual Studios 2008, and need to use the dll's in 'Client3.5' folder. Just in case anyone gets the same issue. Can't access AsyncCtpLibrary.dll and still get problems with Newtonsoft.Ison.dll, but I'm not exactly sure what that's used for yet.


    Just started going through the videos. I added the References to the Client. However when I add them they show a Warning sign on top of them /!\. I figured I would ignore it temporarily, and continue on. However when I try to add in
    'using Raven.Client.Document', it won't detect it. Any help would be greatly appreciated.


    Edit 1 - My project folder is on the desktop, so I thought if I put the Raven-DB folder on the desktop that may solve the issue, unfortunately not. Maybe I've missed a simple step I'll go back through the videos again.

    Edit 2 - It works if I use references to Client3.5, so I assume something is broken within the Client folder? I tried removing the folder and re-downloading, that didn't fix the problem.

    Edit 3 - I tried adding reference path directly, I'm running out of ideas :/
    The "Client" folder works perfectly fine if you're on .net 4 (visual studio 2010). If you're on .net 3.5 (visual studio 2008) then you'll have you use the Client-3.5 folder. Also, although we haven't run into this issue until right now, I generally assume that you're on .net 4. Have you looked at the VS2010 express editions? I can't guarantee everything we'll be doing is compatible with 3.5. Also, if you run into any further issues in the programming VTMs, be sure to state you're on VS2008 in the question
    Last edited by Nelson LaQuet; 02-17-2011 at 07:03 PM.
    Need any help? Feel free to PM me - or send an email directly to nelson@3dbuzz.com!

  3. #3
    Join Date
    Jan 2011
    Posts
    102
    Thanks Nelson appreciate the response. My college provides us with numerous versions of Visual Studios,but I really had no reason to merge over to Visual Studios 2010. I guess now can be a good time to get that switched over.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •