Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1
    Join Date
    Dec 2004
    Posts
    25

    PLEASE HELP! Issue with camera in 3rd person

    I copied the code from all of the VTM's on 3rd person view. When I start the game, my camera bugs into the ground and shakes left and right very quickly. Any ideas?

    Code removed.
    Last edited by Zak; 02-09-2011 at 03:49 PM.

  2. #2
    Join Date
    Sep 2008
    Location
    Salisbury, UK
    Posts
    2,812
    It's possible that your character is slightly intersecting the floor... try raising it up in the air and see what happens when it lands..?
    Last edited by fatgav; 02-09-2011 at 04:05 PM.

    I found
    my current avatar on google, so props to THIS GUY who created the original...

  3. #3
    Join Date
    Jul 2002
    Location
    In space
    Posts
    5,428
    I'm very sorry, but we would appreciate it if you would not post your entire source on the Internet. By all means, put up snippets of specific areas in which you are having problems, but to allow the source to be freely dispersed like this is something we try to avoid.

    Thanks for your understanding.

  4. #4
    Join Date
    Dec 2004
    Posts
    25
    I apologise , this is my first forum post, Yep, i have checked, and the character is above the floor

  5. #5
    Join Date
    Jul 2002
    Location
    UK
    Posts
    164
    Do you have a TargetLookAt attached to your capsule character and is it up near where his eyes are?

  6. #6
    Join Date
    Dec 2004
    Posts
    25
    Quote Originally Posted by Julie1364 View Post
    Do you have a TargetLookAt attached to your capsule character and is it up near where his eyes are?
    Right! i have got somewhere, but it is still in a very buggy state, i can now control my capsule, but the camera is sort of flashing very quickly, and it looks as if it is zooming in and out?

    EDIT: Also after commenting out Reset(), the game starts with the camera inside of the capsule? When i zoom out, the camera goes back to a buggy state again, im getting there i hope

    EDIT2: After some more debugging/testing, it looks as if the camera position keeps reseting, any ideas?
    Last edited by aaronbyrne; 02-09-2011 at 05:47 PM.

  7. #7
    Join Date
    Sep 2008
    Location
    Salisbury, UK
    Posts
    2,812
    Upto what point WAS it working? i.e., which video were you on last time you tested it and it was ok?

    I found
    my current avatar on google, so props to THIS GUY who created the original...

  8. #8
    Join Date
    Dec 2004
    Posts
    25
    Quote Originally Posted by fatgav View Post
    Upto what point WAS it working? i.e., which video were you on last time you tested it and it was ok?
    The video were you test moving with a static camera. The capsule moves fine, its just the camera is jumpy

  9. #9
    Join Date
    Sep 2008
    Location
    Salisbury, UK
    Posts
    2,812
    My only other guess is that you have a collider on something you shouldn't...

    I found
    my current avatar on google, so props to THIS GUY who created the original...

  10. #10
    Join Date
    Dec 2004
    Posts
    25
    What do you mean by that? I have no collision on the capsule. However, I am using terrain? That has collision
    Last edited by aaronbyrne; 02-09-2011 at 06:12 PM.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •