Results 1 to 6 of 6
  1. #1
    Join Date
    Jul 2010
    Posts
    1

    Question Control Vertice Selection Issue (NOT Soft Select)

    I'm having trouble with the 2011 version:

    In one orthographic view, if I LMB-drag-select
    a row of vertices on a NURBS surface, it will only
    select the ones within a certain distance of the orth. camera.

    To test this, I shrank the object down and tried grabbing
    the same row in the side view (the vertice row is going toward/
    away from the side panel's perspective, so they overlap from side view).

    When the object was shrunk down, the whole row was grabbed, as I
    wanted.

    However, I needed to work with it in a larger size.
    I tried LMB-drag-selecting the same row from the side view
    after re-scaling.

    It only selected the vertices on one end, closer to the camera.

    I went into far clipping plane value of the camera, raised it to 30,000
    thinking maybe it was a weird quirk and maybe somehow the ortho. view
    camera was screwed up--- it did not work (and 30,000 was clean overkill).

    I went into window-settings/preferences- preferences- and went down to
    selection.

    I dabbled with all the features of that and the tool settings for the select
    tool, but no matter what I did, the result was always the same.

    Can somebody please help me out with this?
    I just want to be able to LMB-drag-select this row of vertices
    regardless of the objects' scale. It's very distracting and I can't
    learn until I get this off of my plate.

    Thank you very much.

  2. #2
    Join Date
    Feb 2003
    Location
    UK
    Posts
    1,720
    Im sorry I cannot help you fix this but I did recreate the problem.

    If anyone wishes to try this out for themselves then follow these simple intructions:- (I used polygons as it happens to those too).

    1. Click the create plane icon then select all three axis and set it to 350.
    2. Change view to the four windows view and press shift+F to frame up in all four views.
    3. Go in to vertext mode.
    4. As with the problem above use the side view and select any row of verices.
    5. Look in the perspective view and you will see that it doesn NOT select all the way through.

    I tried the "select the viewport camera" trick to change it's near/far settings but that made no difference either. Well Blarney it looks like you are not alone with this problem and I too have Maya 2011 64 bit.
    Intel i7 x5960 @ 4.6GHz (8 cores) | Asus Titan X x2 + MSI Titan X x2 | Asus ROG Rampage V Extreme | 16Gb Corsair Quad Ram | 1 BuRay Writer | 4 x 1TB HD's | Asus PB287Q 4K Gaming Monitor + Dell 24" Monitor | 1500W PSU | 150 Mbps Internet with NTL | Win 10 64 | My Home Page

  3. #3
    Join Date
    Jan 2004
    Location
    Kemptville, Ontario
    Posts
    6,242
    If I followed what everyone is saying, I me being ill is not helping I may know what the problem is.

    Near and far clipping plan is only part of it. Remember each orthographic view and perspective view is a camera. The camera has a place in X, Y, Z. If parts of your model extend to such a distance that they are behind the camera. That distance I believe is about 100.1 units. In each view port go View-Select Camera and look at the X, Y, Z positions.

    Solution is to move the camera back a given number of units to put the mesh in front of the camera. This won't be an issue with orthographic views except you may have to adjust the far clipping plane.

    As I said my heading is pounding and I could very well have misread your posts.

    Best of luck.
    I have figured out what the internet is. You know what they say about an infinite number of monkeys hitting keys at random on an infinite number of typewriters for an infinite amount of time? Well the internet is like that. There is some big cosmic alien running that experiment here in order to find the answer to some big question or to create the greatest piece of literature known to the universe. From what I have seen so far I am sorry to say they are going to be greatly disappointed.

  4. #4
    Join Date
    Mar 2009
    Location
    Heliodeliphilodelphiboschromenos
    Posts
    160
    I know a lot of people hate the viewcube, but interestingly enough using it will fix the problem: it will frame up on that particular side properly.

  5. #5
    Join Date
    Feb 2003
    Location
    UK
    Posts
    1,720
    Hi Benmcl, It would appear that you are right as usual. The manual way to fix this issue would be to click the “Select Camera” icon. Now you can see two tabs in the “Attribute Editor” so choose the “side” tab. Now look in the “Transform Attributes” and increase the “Translate X” until you can select all the verts. Sorry to hear that your not well and I hope you get better soon .

    The automatic way of fixing this issue is to select the side view and click the view box which has “Right” on it. The will adjust the camera’s position automatically. So good call on that Thaqui and you’re right I hate that view cube too.

    So Blarney if you ever get back here and read these post you now have two ways to fix the issue.
    Intel i7 x5960 @ 4.6GHz (8 cores) | Asus Titan X x2 + MSI Titan X x2 | Asus ROG Rampage V Extreme | 16Gb Corsair Quad Ram | 1 BuRay Writer | 4 x 1TB HD's | Asus PB287Q 4K Gaming Monitor + Dell 24" Monitor | 1500W PSU | 150 Mbps Internet with NTL | Win 10 64 | My Home Page

  6. #6
    Join Date
    Feb 2005
    Location
    /..
    Posts
    2,597
    The problem here is caused by the fact that framing up with an ortho' camera changes the Orthographic Width instead of repositioning the camera.
    If you find you are often working on scenes at a large scale it might be worth saving a scene with your ortho' cameras set back a ways, and setting this file as the default new scene
    There is an exception to every rule, apart from this one.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •