Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2008
    Posts
    4

    Unhappy [need help]get error when import wx

    Hi,
    I am working on Ubuntu 9.04, after I installed the latest wxpython in Houdini 10.0.582.
    when I try to import wx module, I got error like this:

    Traceback (most recent call last):
    File "testApp", line 1, in <module>
    File "/opt/hfs10.0.528/houdini/scripts/python/wx/__init__.py", line 45, in
    <module>
    from wx._core import *
    File "/opt/hfs10.0.528/houdini/scripts/python/wx/_core.py", line 62, in <module>
    _core_._wxPySetDictionary(vars())
    TypeError: _wxPySetDictionary must have dictionary object!

    Does anyone has this kind of experience and know how to fix it?

    Thanks!

  2. #2
    Join Date
    Jul 2008
    Posts
    4
    I installed it in ubuntu, by using apt install following the instruction in wxPyhton webpage. The problem happens when I try to import it. In tutorial you guys presented, you showed how to install it in windows, by chose the ansi version and said houdini only support ansi version till now. But when I install using apt, there is no such option for me to choos to use unicode or ansi version, I wonder if that was the core of my problem. Have you ever tried to make it work on Linux? Do I need to compile the wxPyhton using soucre code myself? Could you share your experience with me? Many many thanks!

  3. #3
    Join Date
    Jul 2008
    Posts
    4
    I sloved this issue. Seems I am just being stupid. I point the python 2.5 in houdini to grap the wx module in python 2.6... since Ubuntu has both python 2.5 and 2.6 pre installed, when install wx, it will install for both 2.5 and 2.6, I just repoint Houdini python 2.5 to grap the wx module located in python 2.5 directory..then everything works fine!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •